Social Explorer

Technical Questions

1.   With which browsers is Social Explorer compatible?

Social Explorer supports the following internet browsers:

  • Chrome 58 and newer
  • Firefox 52 and newer
  • Safari 9 and 10
  • Internet Explorer 11
  • Edge 14 and newer
  • Opera 44 and newer

For maps to display, latest Flash version is required. Click here to get or update your flash player.

Pages will also display on other browsers. Please feel free to contact us if you have a specific browser or platform question.
 

2.   Is the site accessible to visually impaired users?

Due to the functionality available on the site, Social Explorer may not be accessible to all visually impaired users.

 

3.   Does Social Explorer support federated searching?

Social Explorer does not currently support federated searching. The dynamic nature of the site, which continually generates maps and reports based on user requests, inhibits federated searching.